Results 1 to 7 of 7

Thread: pptp service failes to start.

  1. #1
    Join Date
    2013-Apr
    Posts
    1

    Question pptp service failes to start.

    Hello,

    Runnig network manager with awus036H. Connected ok to Wifi network.

    apt-get install network-manager-openvpn-gnome
    apt-get install network-manager-pptp
    apt-get install network-manager-pptp-gnome
    apt-get install network-manager-strongswan
    apt-get install network-manager-vpnc
    apt-get install network-manager-vpnc-gnome
    /etc/init.d/network-manager restart

    setup the VPN PPTP, and when I launch VPN connection, ''The VPN connection XXXX failed to start. VPN Failed ''

    It is important to note that the system dosn't even try to initiate.
    This message comes out instantly ( Less than 1 second ). I do not think that this is provider related.


    did all the updates and upgrades of course.

    Any Idea anyone ?

    Cheers.

  2. #2
    Join Date
    2013-Sep
    Posts
    1
    I think I have your problem
    http://bugs.kali.org/view.php?id=565
    any help please

  3. #3
    Join Date
    2013-Sep
    Posts
    1
    i cant create VPN too

  4. #4
    Join Date
    2013-Sep
    Posts
    7
    Quote Originally Posted by ThisIsMaths View Post
    Hello,

    Runnig network manager with awus036H. Connected ok to Wifi network.

    apt-get install network-manager-openvpn-gnome
    apt-get install network-manager-pptp
    apt-get install network-manager-pptp-gnome
    apt-get install network-manager-strongswan
    apt-get install network-manager-vpnc
    apt-get install network-manager-vpnc-gnome
    /etc/init.d/network-manager restart

    setup the VPN PPTP, and when I launch VPN connection, ''The VPN connection XXXX failed to start. VPN Failed ''

    It is important to note that the system dosn't even try to initiate.
    This message comes out instantly ( Less than 1 second ). I do not think that this is provider related.


    did all the updates and upgrades of course.

    Any Idea anyone ?

    Cheers.
    In NetworkManager under your pptp vpn configuration window, check or uncheck/recheck the 'Connect Automatically' and/or 'Available to all users' and then try connecting again to your pptp vpn. Play around with those check boxes, and try re-connecting to your vpn. I think i had this problem a while back, I can't be 100% sure but i think this May have solved the issue for me. (the issue being NetworkManager displaying 'connection failed' right away, after attempting to connect to a vpn via NetworkManager)

  5. #5
    Join Date
    2013-Jul
    Posts
    42
    Don't think this is a dedicated Kali problem...

    https://answers.launchpad.net/ubuntu/+source/network-manager/+question/48503


    Several Ubuntu users reported this fault - it could well be your settings in the configuration window, as elfer has suggested. These users also mentioned the "Available to all users" solution that elfer pointed out - so this looks pretty likely to be a work around for you.

    Here's what I found:
    Open Network Configuration (Start, System, Preferences).
    Highlight your VPN connection, hit Edit.
    At IPv4 Settings Tab: choose method Automatic (VPN).
    At VPN Tab:
    1 - input the IP address of the target computer.
    2 - input your user name. Leave all else blank.
    3 - hit Advanced button.
    At Authentication:
    1 - UNcheck PAP (because PAP means to allow unsecured passage - this is the source of "no shared shared secrets")

    2 - Check CHAP, MSCHAP and MSCHAPv2.
    At Security and Compression:
    1 - Check Use Point-to-point encryption (MPPE)
    2 - Select 128-bit (most secure).
    3 - Check Allow stateful encryption.
    At Echo: check Allow PPP echo packets.
    Leave all else blank. Hit OK, OK to save and get out.

    Note: Your password is requested on VPN startup. I did not try to add it to the keyring.

    Sonya's point to deselect PAP was the key point that I think got this working. tyvm!

    Big discussion here
    http://ubuntuforums.org/showthread.php?t=991144

    Hope these links provide a solution.

  6. #6
    Join Date
    2013-Sep
    Posts
    264
    In my case with vyprvpn and the Gnome network manager, some settings are slightly different

    At VPN Tab:
    1 - input the IP address of the target computer.
    2 - input your user name. Leave all else blank.
    3 - hit Advanced button.
    For me there is n need to enter the ip adress of the target computer just the url of the chosen VPN. The rest is as you said, just enter the user name and the pass and go to avanced



    For the rest is the same basicaly, just i was advised to leave only MSCHAPv2.



    Once you have configurated a little list of VPN it is very handy and perfectly integrated, I like it.

  7. #7
    Join Date
    2013-Sep
    Posts
    7
    uwnthesis is right. I totally forgot about step's 2-3 because I use OpenVPN most of the time. The step's uwnthesis posted above are a must when using PPTP VPN's in network-manager.

Similar Threads

  1. Failed #service postgresql start
    By Castor_Troy in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-06-25, 00:39

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •