Results 1 to 4 of 4

Thread: Rolling Kali and updating issues

  1. #1
    Join Date

    Rolling Kali and updating issues

    I haven't had much luck using the rolling repo listed at

    On one, it was a fresh install of 64-bit 2016.1. Perhaps I initially updated it using the default repos (I don't recall), but then I edited the /etc/apt/sources.list and commented out the two default repos, and then added:

    deb kali-rolling main contrib non-free

    (so to confirm, the above line was the ONLY active entry in my sources.list file)

    Then I do a 'apt-get update && apt-get dist-upgrade', and it keeps getting stuck (more like looping, as if it's trying to do a GET over and over again on the same file).

    In another case, it was an existing Kali I've had installed for a while:

    PRETTY_NAME="Kali GNU/Linux 2.0 (sana)"
    NAME="Kali GNU/Linux"
    VERSION="2.0 (sana)"

    I did the same thing (commented out the default sources.list entries and added the rolling one), I kept running into issues, then tried with a 'apt-get update && apt-get dist-upgrade -f' , then at some point in retrying it looked like it was done and to test I rebooted and it wouldn't boot up.

    So am I doing this right or should I have more than one line in my /etc/sources.list file.

    I must be doing something wrong as I don't see other people having all kinds of issues.


  2. #2
    as says.. for rolling the right rep are

    deb kali-rolling main contrib non-free

    deb-src kali-rolling main contrib non-free

    this is how your /etc/apt/sources.list should look like
    for kali sana should look like this

    deb sana main non-free contrib
    deb sana/updates main contrib non-free
    deb-src sana main non-free contrib
    deb-src sana/updates main contrib non-free

  3. #3
    Join Date
    Ok thanks so the only difference with what I was trying, was that I had the deb-src rolling line commented out.

    I'm trying it again now on both systems, on one it's still running so I'll cross my fingers.

    On the older build that I've been using a while (the details in my first post), it is erroring with:

    Calculating upgrade... Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    gnome-packagekit : Breaks: gnome-packagekit-session (< 3.16.0) but 3.14.0-1 is to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    I tried it these ways:

    apt-get update && apt-get dist upgrade
    apt-get update && apt-get dist upgrade -f

    What is the best way to overcome this?

    Thanks again

  4. #4
    i don't use rolling, but from what i heard "&&" doesn't always work. so try them one by one
    apt-get update
    apt-get upgrade
    apt-get dist-upgrade

Similar Threads

  1. Updating 2.0 to Rolling -Black Screen
    By xunil ilak in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2018-05-08, 16:39
  2. Kali Boot Freezes After Updating from 2.0 to Rolling
    By ellcrys in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2017-02-18, 05:12
  3. GNOME visual issues after updating/upgrading Kali Rolling
    By Koah Nuttler in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2016-05-15, 09:04
  4. Updating Kali Rolling Ditro
    By MrJester in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2016-03-18, 11:19

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts