Results 1 to 1 of 1

Thread: Problem during installing mana-toolkit on Nethunter on Nexus 5x

  1. #1
    Join Date
    2015-Oct
    Posts
    11

    Unhappy Problem during installing mana-toolkit on Nethunter on Nexus 5x

    root@kali:~# apt-get install mana-toolkit
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    john john-data metasploit-framework nasm postgresql postgresql-9.4 stunnel4
    Suggested packages:
    postgresql-doc oidentd ident-server logcheck-database
    The following NEW packages will be installed:
    john john-data mana-toolkit metasploit-framework nasm postgresql postgresql-9.4 stunnel4
    0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
    Need to get 21.4 MB/84.1 MB of archives.
    After this operation, 230 MB of additional disk space will be used.Do you want to continue? [Y/n] y
    Get:1 http://http.kali.org/kali/ sana/main john-data all 1.8.0.6-jumbo-1-0kali2 [18.6 MB]
    Get:2 http://security.kali.org/ sana/updates/main stunnel4 armhf 3:5.06-2+deb8u1 [172 kB]
    Get:3 http://http.kali.org/kali/ sana/main john armhf 1.8.0.6-jumbo-1-0kali2 [1222 kB]
    Get:4 http://http.kali.org/kali/ sana/main nasm armhf 2.11.05-1 [1440 kB]
    Fetched 21.4 MB in 2min 17s (156 kB/s)
    Selecting previously unselected package stunnel4.
    (Reading database ... 154077 files and directories currently installed.)
    Preparing to unpack .../stunnel4_3%3a5.06-2+deb8u1_armhf.deb ...
    Unpacking stunnel4 (3:5.06-2+deb8u1) ...
    Selecting previously unselected package john-data.
    Preparing to unpack .../john-data_1.8.0.6-jumbo-1-0kali2_all.deb ...
    Unpacking john-data (1.8.0.6-jumbo-1-0kali2) ...
    Selecting previously unselected package john.
    Preparing to unpack .../john_1.8.0.6-jumbo-1-0kali2_armhf.deb ...
    Unpacking john (1.8.0.6-jumbo-1-0kali2) ...
    Selecting previously unselected package postgresql-9.4.
    Preparing to unpack .../postgresql-9.4_9.4.6-0+deb8u1_armhf.deb ...Unpacking postgresql-9.4 (9.4.6-0+deb8u1) ...Selecting previously unselected package postgresql.
    Preparing to unpack .../postgresql_9.4+165_all.deb ...
    Unpacking postgresql (9.4+165) ...
    Selecting previously unselected package nasm.
    Preparing to unpack .../nasm_2.11.05-1_armhf.deb ...
    Unpacking nasm (2.11.05-1) ...
    Selecting previously unselected package metasploit-framework.
    Preparing to unpack .../metasploit-framework_4.11.5-2016010401-0kali1~r1u1_armhf.deb ...
    Unpacking metasploit-framework (4.11.5-2016010401-0kali1~r1u1) ...
    Selecting previously unselected package mana-toolkit.
    Preparing to unpack .../mana-toolkit_0~20150707-0kali2_armhf.deb ...
    Unpacking mana-toolkit (0~20150707-0kali2) ...
    Processing triggers for man-db (2.7.0.2-5) ...
    Processing triggers for systemd (215-17+deb8u1) ...
    Processing triggers for postgresql-common (165) ...
    supported-versions: WARNING! Unknown distribution: kali
    debian found in ID_LIKE, treating as Debian
    supported-versions: WARNING: Unknown Debian release: 2.0
    Building PostgreSQL dictionaries from installed myspell/hunspell packages...
    Removing obsolete dictionary files:
    Setting up stunnel4 (3:5.06-2+deb8u1) ...
    SSL tunnels disabled, see /etc/default/stunnel4
    Setting up john-data (1.8.0.6-jumbo-1-0kali2) ...
    Setting up john (1.8.0.6-jumbo-1-0kali2) ...
    mode of '/var/run/john' changed from 0755 (rwxr-xr-x) to 0700 (rwx------)
    Setting up postgresql-9.4 (9.4.6-0+deb8u1) ...
    update-alternatives: using /usr/share/postgresql/9.4/man/man1/postmaster.1.gz to provide /usr/share/man/man1/postmaster.1.gz (postmaster.1.gz) in auto mode
    [....] Starting PostgreSQL 9.4 database server: main[....] The PostgreSQL server failed to start. Please check the log output: 2016-07-04 05:23:04 UTC [21747-1] FATAL: could not create shared memory segment: Function not implemented 2016-07-04 05:23:04 UTC [21747-2] DETAIL: Failed system call was shmget(key=5432001, size=40, 03600). .[F failed!
    failed!
    invoke-rc.d: initscript postgresql, action "start" failed.
    dpkg: error processing package postgresql-9.4 (--configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of postgresql:
    postgresql depends on postgresql-9.4; however:
    Package postgresql-9.4 is not configured yet.

    dpkg: error processing package postgresql (--configure):
    dependency problems - leaving unconfigured
    Setting up nasm (2.11.05-1) ...
    dpkg: dependency problems prevent configuration of metasploit-framework:
    metasploit-framework depends on postgresql; however:
    Package postgresql is not configured yet.

    dpkg: error processing package metasploit-framework (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of mana-toolkit:
    mana-toolkit depends on metasploit-framework; however:
    Package metasploit-framework is not configured yet.

    dpkg: error processing package mana-toolkit (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    postgresql-9.4
    postgresql
    metasploit-framework
    mana-toolkit
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    root@kali:~#
    Last edited by real0001; 2016-07-04 at 06:17. Reason: notification

Similar Threads

  1. NetHunter 3.0 Nexus 7 2013 (6.0.1) TL-WN722N MANA
    By anonymous_14386 in forum NetHunter General Questions
    Replies: 0
    Last Post: 2016-04-22, 21:09
  2. [problem] installing nethunter on NEXUS 10
    By petitradisgris in forum Installing NetHunter
    Replies: 0
    Last Post: 2015-08-23, 13:07
  3. Mana toolkit no upstream help
    By mroy1300 in forum General Archive
    Replies: 2
    Last Post: 2015-07-16, 18:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •