Results 1 to 6 of 6

Thread: Problems with apt-get update

  1. #1
    Join Date

    Problems with apt-get update

    Hi all, i just recently installed Kali Linux as a VM using VirtualBox, and i'm having some trouble..

    Initially, during the *configuring apt* part of the install, it never finds a mirror, so i have to skip that part. Then, once the install is over, inside Kali, i have to manually add the mirror to /etc/apt/sources.list, so i add :

    deb kali-rolling main non-free contrib
    However, after doing this, when i try apt-get update, i get the following error:

    # apt-get clean && apt-get update
    Reading package lists... Done
    E: Method http has died unexpectedly!
    E: Sub-process http received a segmentation fault
    There's nothing about it in /var/log/apt/* or any other logs that i can see...

    Also i should mention, it isn't a network problem, i can ping IP's and navigate to http addresses just fine...

    I thought it may be a VirtualBox issue, but if i boot into the Kali LiveCD, apt works fine. Also other distros i have in VirtualBox (Ubuntu, Debian, Arch), all work fine with their package managers.

    Any help would be greatly appreciated... Thanks!

  2. #2
    Join Date

  3. #3
    Join Date
    Kali forums
    Have you verified the hashes from your download? Maybe something went wrong there.

  4. #4
    Join Date
    I eventually got it working, i tried ever mirror and eventually found one that worked

    I'm still not sure what was causing the majority of mirrors to result in a segmentation fault though...

  5. #5
    Join Date
    Just to expand on this a bit, i've narrowed down what the problem was

    For some reason, on the fresh install, apt (version 1.1.10) had some problem with the mirrors, and kept seg faulting. I had to try all the mirrors until one finally worked (the one which worked for me was : Then, simply:

    apt-get clean && apt-get update && apt-get install apt
    This updated apt to v1.3-pre3, and also updated apt-utils from 1.1.10 to v1.3-pre3

    I was able to change my mirror back to, or use any of the others on the list, they all worked fine

    I'm not sure if it was a problem with apt, or apt-utils, as both got upgraded when i upgraded apt, but either way, this is how i got it working.

  6. #6
    Join Date
    My Apt-Get is really slowly. I tried change the sources but the issue persist. My connection is good to any site, torrent or anything else. I'm getting just 100kB/s on Kali and apt-get on another linuxs I get 1MB/s. How to solve it?

Similar Threads

  1. Problems with apt-get update - Live 2023-2 64-bit,
    By newbie-02 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2023-08-15, 10:55
  2. apt update problems
    By Arturteva in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2019-12-13, 17:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts