Results 1 to 5 of 5

Thread: NEED DEVS! wifite is outdated & needs to be replaced

  1. #1
    Join Date

    NEED DEVS! wifite is outdated & need mainteinance

    Hi there!

    wifite got so much problems these days, because of the tools it supported before have been updated/changed..
    * WASH implementation is broken, giving bad scan results for WPS (LOCKED search also fails)
    * tshark got updated, changing some options -- therefor the tshark impl. also is bad (params)
    * reaver got updated, changing some options -- therefor reaver impl. is kinda broken
    * mac addr patch is needed (macchanger)

    The maintainer derv82 seems inactive at the time, but we (THE COMMUNITY) did some work
    to actually fix most of these problems + some others.

    Take a look at the "next generation" "wifite", dubbed "wifite-ng" @

    - pingen attack implemented
    - pixie dust (pixiewps) attack included
    - macchanger patched
    - tshark fixed
    - reaver fixed

    But to maintain this tool in the future, we need your help too! Take a look around the code & todo list and we'll be happy to receive future request/additions/ideas that you may have.

    Thanks to "binkybear", "brianclemens" and all other listed in the for making "wifite" work again. And of course to "derv82" for making this tool in the first place (",)

    The original source, by the developer "derv82" is to be found @

    -- Christian <kimocoder>
    Last edited by kimocoder; 2017-05-12 at 08:10. Reason: Update #1

  2. #2
    Join Date
    This sounds like a great idea. I love the way wifite works. Obviously the component tools it uses can be driven independently to achieve the same results. But man is (was) it nice to have essentially one command to do everything at once.

    Privately I've hacked on my own latest copy of wifite (fix interface MAC parsing, tshark issue, wash args, etc). But I feel like it's all very fragile and needs a solid-redo while preserving the original structure of how wifite worked. I'm not solid enough in python (I'm a more of a perl old timer, and not a very good one...) to really contribute though.

  3. #3
    Join Date
    Just saw your update to the thread and grabbed it. Good work, and many thanks.

    I ran it quickly testing WPA HS, WEP and WPS (Pixie). WPA HS and WEP (arp replay tested) work textbook.

    WPS pixie seems to hang though. The status line has an incrementing counter, and initially it seems to say something like "Restore session for xx:xx:xx:xx:xx:xx [n/Y]". It then says waiting and doesn't seem to do anything. I do see reaver running via ps. Also - I ran this test against one of my own routers that is known vulnerable to pixie. Running the latest Kali rolling.

    Let me know what I can do to troubleshoot and any/all details you need from me.

    I wanted to add some more details in the meantime. My test router is a Belkin, and I see that you now have logic to look for Belkin/DLink OUIs and target them using pingen. I thought this might have been causing an issue - so I copied your script and removed my OUI from the belkin array. Even without detecting it as Belkin (and I assume this skips pingen as well) - it still hangs in the same manner.

    UPDATE 2:
    I may have made some progress on why it hangs at Restore session. It seems that reaver writes out brute session files to /etc/reaver on Kali. By default, if this exists for the BSSID at hand, reaver will interactively ask if you want to restore from it. So at any time, if you ran a brute WPS against it (i.e. pixie fails or you control-c or you ran reaver manually) - you will likely have a session file.

    It seems like the older/original wifite uses a "-s n" argument to reaver when running pixie - and this tells it not to try to restore from session.

    A bit more bad news though, after I manually deleted my session file for my test router and ran your wifite - pixie seems to hang at "Waiting". I also looked at your code and it seems that there is some kind of version check for reaver (i.e. "new" vs. "old"). I am testing this is on an updated Kali. I believe the reaver version if 1.53. Seems like the reaver detection and args are just missing something and it gets stuck.

    Also - let me know if you want me to consolidate this and put it into a github issue. Thanks.
    Last edited by vom; 2017-05-27 at 20:38. Reason: Update 2

  4. #4
    Join Date
    Thanks for reporting, will look into it this weekend.

    There are some issues still yet, which are the primary goal to fix asap, will update this thread today for more information. Again, thanks for the feedback -- will get back to you soon

  5. #5
    is this supposed to work with Nethunter? I'm trying to get it to work on a nexus 10 but it loops back after enabling monitor mode, its the same with the original wifite script but that one i can start with wifite --mon-iface wlan1mon

Similar Threads

  1. Contact Devs error, arm64 chroot
    By opUserZero in forum Installing Archive
    Replies: 0
    Last Post: 2021-12-22, 19:00
  2. How to fix outdated upstreams
    By LazyCoder in forum General Archive
    Replies: 4
    Last Post: 2018-12-31, 05:49
  3. Replies: 1
    Last Post: 2016-07-22, 21:11
  4. Back slash replaced with hash
    By skycrazy in forum NetHunter General Questions
    Replies: 1
    Last Post: 2014-10-11, 07:27

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts