Results 1 to 6 of 6

Thread: Infinity Loop - A Start Job is running for live-config contains the components

  1. #1
    Join Date
    2017-Oct
    Posts
    4

    Infinity Loop - A Start Job is running for live-config contains the components

    Hello All,

    I would like to truly kindly ask you for help, since im helpless already. Im trying to boot Kali Linux Live USB, with version Kali 64bit 2017.2 (kali-linux-2017.2-amd64). Using program Win32 Disk Imager 1.0 with USB SanDisk CruzerBlade 16GB. However, when im trying to boot the linux, I tried to choose almost everything (persistance, forensic and so on.) but it is always stucked on booting screen.

    Screehshot: https://ibb.co/kNcSoG

    I have no clue why, my laptop is Asus Rog GL553VE, i7 7700HQ Kaby Lake, Nvidia 1050Ti, 16gb ram, 126GB SSD, 1TB HDD. Can it be problem with configuration ? I literally read everything regarding this issue on google, and I didnt find any solution. Therefore im creating own thread, and hopefully if someone has same issue, it will be helpful.

    Thank you in advance guys.

  2. #2
    Join Date
    2017-Oct
    Posts
    4
    Press E in GRUB (graphical option for Live mode, Persistent etc.) and adjust line:

    You need to add nouveau.modeset=0 after this line "linux /live/vmlinuz-4.12.0-kali1-amd64 boot=live components splash username=root hostname=kali"
    So, it would look like this:
    linux /live/vmlinuz-4.12.0-kali1-amd64 boot=live components splash username=root hostname=kali nouveau.modeset=0
    Then press F10 and you should be in.

    This is the answer, I found that on reddit. Thanks guys.

  3. #3
    Join Date
    2017-Nov
    Posts
    1
    Hi,
    got same problem, could you be a little more specific how to do it ? I assume u mean the boot menu where u can choose live mode/ presistence or install but when pressing E nothing happens. Did it solve all your problems?

  4. #4
    Join Date
    2017-Oct
    Posts
    3
    hiLogic, if you boot from GRUB loader u use e, if you load directly from quick boot menu choose to boot from usb and then when you get option select to boot live or, persistence pres TAB, separate with one SPACE key and then type nouveau.modeset=0, and just press ENTER. after this Kali should boot in with no problems. this is a workaround, that I haven't so far found the way hot to permanently solve so every time you boot in to kali you need to perform this step, but at least you will be able to use it on your laptop.

  5. #5
    Join Date
    2017-Nov
    Posts
    3
    Thank you so much Alokinikola, it works for me. I had to change the pci setting too. Is it possible to set those changes permanently?

  6. #6
    Join Date
    2017-Dec
    Posts
    1
    Quote Originally Posted by Ramsay View Post
    Thank you so much Alokinikola, it works for me. I had to change the pci setting too. Is it possible to set those changes permanently?
    Hello my friend,

    You can do this:

    Go in your usb drive with kali there to:

    \boot\grub\grub.cfg

    open it with notepad.

    do a search in the notepad for one word of those ones: "username=root hostname=kali" and insert "nouveau.modeset=0".

    Do this in every lane of it to config the different boot modes with nouveau modeset.

    Enjoy

Similar Threads

  1. A start job is running for live-config contains... Problem
    By oguzhan002 in forum Installing Kali Linux
    Replies: 3
    Last Post: 2017-11-04, 16:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •