Results 1 to 3 of 3

Thread: Graphic artifacts with Ryzen 5 2400G

  1. #1
    Join Date

    Graphic artifacts with Ryzen 5 2400G

    First of all, I'm very new so I apologize in advance for any mistakes, overlooks, etc.

    I flashed Kali Live 2020 to an USB flash drive using three different methods, all three yielded the same result. The latest one was using Rufus 3.7, adding a persistent partition.
    When I start Kali for the first time, everything works as far as I can tell. Second time I start, a green screen appears after the logo. If I leave it enough time (till the screen goes off) the login screen eventually appears.
    Then, it works very slow and with graphical glitches. I tried to capture screenshots but they come out fine, so I took a pic with my phone.

    I also tried using balenaEtcher and manually creating the persistence partition, same thing happens, as well as using MiniTool Partition Wizard (I have a Windows 10 system). I used different media and it didn't change anything.
    This doesn't happen if I don't create a persistence partition.
    I also updated my BIOS (Gigabyte AB350N) to the latest version, same results.
    I also tried installing amdgpu-pro but wasn't able to.

    Any help would be appreciated!
    Attached Images Attached Images

  2. #2
    Join Date
    hey, im not a pro with this stuff. i tried to install kali on my amd ryzen3 2200g and im facing the same problem.ive tried installing 2 times. it loads fine for the first time but at the second time after entering username and password the screen goes green.
    you must try doing sudo apt-get update and sudo apt-get upgrade on the terminal. you can go to the terminal from the username and psswd screen by pressing CTRL + ALT + F4.
    ive tried this but i couldnt complete cus of my broke internet .
    give it a shot. i dont really know whether it will work or not and i also think this can be an issue of APU.

  3. #3
    Join Date
    i am using ryzen 7 4800hs using the new renoir (amdgpu) graphics driver.
    i do get residual artifacts like these.
    what solved for me was changing the resolution and refresh rate in X.

    my hardware outputs on eDP and the LCD has a refresh rate of 144hz so for me it was

    xrandr --output eDP --mode 1920x1080 --rate 60
    xrandr --output eDP --mode 1920x1080 --rate 144

    to check yours.


    look for the output, mode and rate supported.

    hope it helps.

Similar Threads

  1. Screen Refresh Issue & Graphic Artifacts
    By Stygian Blue in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2020-05-04, 16:02
  2. Replies: 0
    Last Post: 2020-03-12, 15:03
  3. Replies: 0
    Last Post: 2015-09-09, 01:39
  4. Replies: 0
    Last Post: 2013-12-07, 16:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts