Results 1 to 6 of 6

Thread: Unable to install new packages

  1. #1
    Join Date
    2014-Aug
    Posts
    7

    Unable to install new packages

    Hello, I have installed 2020.1. Everything seems fine, but I am not able to install new packages. I keep getting the E:/ unable to locate package message.

    I was trying doing some reading and it seems like it might be my sources list. I checked it out with nano and I only have one repository listed. I do not have the src one...

    I was wondering, what are the repositories I should have? I believe it is two from what I have read and seen in documentation...

  2. #2
    Join Date
    2014-Aug
    Posts
    7
    Quote Originally Posted by kalinoob1 View Post
    Hello, I have installed 2020.1. Everything seems fine, but I am not able to install new packages. I keep getting the E:/ unable to locate package message.

    I was trying doing some reading and it seems like it might be my sources list. I checked it out with nano and I only have one repository listed. I do not have the src one...

    I was wondering, what are the repositories I should have? I believe it is two from what I have read and seen in documentation...

    This is what my Sources.list has in it:
    deb http://http.kali.org/kali kali-rolling main non-free contrib
    deb-src http://http.kali.org/kali kali-rolling main non-free contrib

    When I try to update, it goes out looking for headers and to the mirrors, then tries to connect and I get a message that says:
    E: Release file for http://http.kali.org/kali/dists/kali-rolling/InRelease is not valid yet (invalid for another 6h 24min 19s).
    Updates for this repository will not be applied.

  3. #3
    Join Date
    2020-May
    Posts
    4
    you can try reinstalling so "apt full-upgrade" see if that works

  4. #4
    Join Date
    2020-May
    Posts
    2
    I am having the same issue. I can't even install the meta packages and have followed several tutorials on having the right repos, including the official docs. Was you able to find a solution?

  5. #5
    Join Date
    2020-May
    Posts
    2
    Not sure exactly what you are trying to install, but if it is the metapackages, here is the new an updated way of doing. ProTip: Sometimes the documentation helps.
    https://www.kali.org/news/major-metapackage-makeover/

  6. #6
    Join Date
    2020-Apr
    Location
    dhaka, Bangladesh
    Posts
    1
    hi all, can you help me install tomcat6; i have updated etc/apt/ Sources.list file as per kali repository document including source repository code. done update; but still it shows the error:E: "Unable to locate package tomcat6" . your support is highly appreciated. thax. Azad

Similar Threads

  1. Unable to locate PHP packages
    By arsitek in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2015-04-14, 15:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •