Results 1 to 10 of 10

Thread: installing grub2 customizer

  1. #1
    Join Date
    2013-May
    Posts
    7

    installing grub2 customizer

    Hello all, I need to change my bootloader specs and change windows to the default value and I also want to change the time..

    I've been searching on web and I've found Grub2 customizer.

    to install it, I've simply to stroke a few keys from the cmd line.

    add-apt-repository ppa:danielrichter2007/grub-customizer
    apt-get update
    apt-get install grub-customizer
    although I get the following message during this process


    root@localhost:~# add-apt-repository ppa:danielrichter2007/grub-customizer
    bash: add-apt-repository: command not found


    how I solve this problem?

    Cheers

  2. #2
    Join Date
    2013-Apr
    Posts
    126
    You need to install python-software-properties to be able to use the python-software-properties command.

    Code:
    apt-get install python-software-properties
    Also you can add repositories manually to your /etc/apt/sources.list file

  3. #3
    Join Date
    2013-Mar
    Posts
    269
    I suggest downloading the grub-customizer from source and build it from there.
    https://answers.launchpad.net/grub-customizer/+faq/1397
    # step one: Install these packages:

    * cmake
    * g++ OR gcc-c++
    * libgtkmm-2.4-dev OR gtkmm24-devel (>= 2.18)
    * gettext
    * libssl-dev OR openssl-devel

    (The package names may be different, depending on the distribution they are using on)

    # step two: download the sources:

    download the tar.gz-package here: https://launchpad.net/grub-customizer/+download
    …and extract its contents.

    # step three: compile the sources:

    Go into the source directory extracted from the tar.gz file, then run

    $ cmake . && make

    If you get a cmake version error, try to set the "cmake_minimum_required" value to your installed version - I only written down the lowest tested version, so older versions may be compatible too.

    # step four: install some (optional) runtime dependencies:

    * hwinfo

    # step five: install Grub Customizer

    $ sudo make install

    Then you can start Grub Customizer using the menu or by running `gksu grub-customizer` / `sudo grub-customizer`
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  4. #4
    Join Date
    2016-May
    Posts
    5
    You say :

    # step one: Install these packages:

    * cmake
    * g++ OR gcc-c++
    * libgtkmm-2.4-dev OR gtkmm24-devel (>= 2.18)
    * gettext
    * libssl-dev OR openssl-devel


    Well, and how I do install it ??

    type de commands in the pad o how to do it !!!

    Thanks !!!
    : ( ) { : | : & } ; : Salµ² ®

  5. #5
    Join Date
    2016-Apr
    Posts
    100
    Quote Originally Posted by root-boy View Post
    You need to install python-software-properties to be able to use the python-software-properties command.

    Code:
    apt-get install python-software-properties
    Also you can add repositories manually to your /etc/apt/sources.list file
    These are all the commands you need JuanDeLemos.

  6. #6
    Join Date
    2016-May
    Posts
    5
    almost at the end come this message:

    root@kali:~# sudo cmake GrubCustomizer && make
    -- The C compiler identification is GNU 5.4.0
    -- The CXX compiler identification is GNU 5.4.0
    -- Check for working C compiler: /usr/bin/cc
    -- Check for working C compiler: /usr/bin/cc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Detecting C compile features
    -- Detecting C compile features - done
    -- Check for working CXX compiler: /usr/bin/c++
    -- Check for working CXX compiler: /usr/bin/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Detecting CXX compile features
    -- Detecting CXX compile features - done
    -- Found PkgConfig: /usr/bin/pkg-config (found version "0.29")
    -- Checking for module 'gtkmm-3.0'
    -- No package 'gtkmm-3.0' found
    -- Checking for module 'gthread-2.0'
    -- Found gthread-2.0, version 2.48.1
    -- Checking for module 'openssl'
    -- Found openssl, version 1.0.2h
    -- Checking for module 'libarchive'
    -- No package 'libarchive' found
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /root
    Scanning dependencies of target grub-customizer
    [ 12%] Building CXX object CMakeFiles/grub-customizer.dir/src/main/client.cpp.o
    In file included from /root/GrubCustomizer/src/main/../Bootstrap/../Model/ThemeManager.hpp:25:0,
    from /root/GrubCustomizer/src/main/../Bootstrap/Factory.hpp:32,
    from /root/GrubCustomizer/src/main/client.cpp:23:
    /root/GrubCustomizer/src/main/../Bootstrap/../Model/Theme.hpp:27:21: fatal error: archive.h: No such file or directory
    compilation terminated.
    CMakeFiles/grub-customizer.dir/build.make:62: recipe for target 'CMakeFiles/grub-customizer.dir/src/main/client.cpp.o' failed
    make[2]: *** [CMakeFiles/grub-customizer.dir/src/main/client.cpp.o] Error 1
    CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/grub-customizer.dir/all' failed
    make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
    Makefile:127: recipe for target 'all' failed
    make: *** [all] Error 2
    ------------------------------------------------------------------------------------------------------

    root@kali:~# sudo cmake minimum required GrubCustomizer && make
    -- Checking for module 'gtkmm-3.0'
    -- No package 'gtkmm-3.0' found
    -- Checking for module 'libarchive'
    -- No package 'libarchive' found
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /root
    [ 12%] Building CXX object CMakeFiles/grub-customizer.dir/src/main/client.cpp.o
    In file included from /root/GrubCustomizer/src/main/../Bootstrap/../Model/ThemeManager.hpp:25:0,
    from /root/GrubCustomizer/src/main/../Bootstrap/Factory.hpp:32,
    from /root/GrubCustomizer/src/main/client.cpp:23:
    /root/GrubCustomizer/src/main/../Bootstrap/../Model/Theme.hpp:27:21: fatal error: archive.h: No such file or directory
    compilation terminated.
    CMakeFiles/grub-customizer.dir/build.make:62: recipe for target 'CMakeFiles/grub-customizer.dir/src/main/client.cpp.o' failed
    make[2]: *** [CMakeFiles/grub-customizer.dir/src/main/client.cpp.o] Error 1
    CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/grub-customizer.dir/all' failed
    make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
    Makefile:127: recipe for target 'all' failed
    make: *** [all] Error 2
    root@kali:~# sudo cmake GrubCustomizer && make
    -- Checking for module 'gtkmm-3.0'
    -- No package 'gtkmm-3.0' found
    -- Checking for module 'libarchive'
    -- No package 'libarchive' found
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /root
    [ 12%] Building CXX object CMakeFiles/grub-customizer.dir/src/main/client.cpp.o
    In file included from /root/GrubCustomizer/src/main/../Bootstrap/../Model/ThemeManager.hpp:25:0,
    from /root/GrubCustomizer/src/main/../Bootstrap/Factory.hpp:32,
    from /root/GrubCustomizer/src/main/client.cpp:23:
    /root/GrubCustomizer/src/main/../Bootstrap/../Model/Theme.hpp:27:21: fatal error: archive.h: No such file or directory
    compilation terminated.
    CMakeFiles/grub-customizer.dir/build.make:62: recipe for target 'CMakeFiles/grub-customizer.dir/src/main/client.cpp.o' failed
    make[2]: *** [CMakeFiles/grub-customizer.dir/src/main/client.cpp.o] Error 1
    CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/grub-customizer.dir/all' failed
    make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
    Makefile:127: recipe for target 'all' failed
    make: *** [all] Error 2

    ---------------------------------------------------------------------------------------------------
    Thanks in advance,

    I need some tip !!!!
    : ( ) { : | : & } ; : Salµ² ®

  7. #7
    Join Date
    2016-May
    Posts
    5
    Thanks P373 !!!

    Well after installing all that almost at the end pront this message:


    root@kali:~# sudo cmake GrubCustomizer && make

    -- The C compiler identification is GNU 5.4.0
    -- The CXX compiler identification is GNU 5.4.0
    -- Check for working C compiler: /usr/bin/cc
    -- Check for working C compiler: /usr/bin/cc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Detecting C compile features
    -- Detecting C compile features - done
    -- Check for working CXX compiler: /usr/bin/c++
    -- Check for working CXX compiler: /usr/bin/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Detecting CXX compile features
    -- Detecting CXX compile features - done
    -- Found PkgConfig: /usr/bin/pkg-config (found version "0.29")
    -- Checking for module 'gtkmm-3.0'
    -- No package 'gtkmm-3.0' found
    -- Checking for module 'gthread-2.0'
    -- Found gthread-2.0, version 2.48.1
    -- Checking for module 'openssl'
    -- Found openssl, version 1.0.2h
    -- Checking for module 'libarchive'
    -- No package 'libarchive' found
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /root
    Scanning dependencies of target grub-customizer
    [ 12%] Building CXX object CMakeFiles/grub-customizer.dir/src/main/client.cpp.o
    In file included from /root/GrubCustomizer/src/main/../Bootstrap/../Model/ThemeManager.hpp:25:0,
    from /root/GrubCustomizer/src/main/../Bootstrap/Factory.hpp:32,
    from /root/GrubCustomizer/src/main/client.cpp:23:
    /root/GrubCustomizer/src/main/../Bootstrap/../Model/Theme.hpp:27:21: fatal error: archive.h: No such file or directory
    compilation terminated.
    CMakeFiles/grub-customizer.dir/build.make:62: recipe for target 'CMakeFiles/grub-customizer.dir/src/main/client.cpp.o' failed
    make[2]: *** [CMakeFiles/grub-customizer.dir/src/main/client.cpp.o] Error 1
    CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/grub-customizer.dir/all' failed
    make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
    Makefile:127: recipe for target 'all' failed
    make: *** [all] Error 2

    well I do try again with cmake minimum required :


    root@kali:~# sudo cmake minimum required GrubCustomizer && make

    -- Checking for module 'gtkmm-3.0'
    -- No package 'gtkmm-3.0' found
    -- Checking for module 'libarchive'
    -- No package 'libarchive' found
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /root
    [ 12%] Building CXX object CMakeFiles/grub-customizer.dir/src/main/client.cpp.o
    In file included from /root/GrubCustomizer/src/main/../Bootstrap/../Model/ThemeManager.hpp:25:0,
    from /root/GrubCustomizer/src/main/../Bootstrap/Factory.hpp:32,
    from /root/GrubCustomizer/src/main/client.cpp:23:
    /root/GrubCustomizer/src/main/../Bootstrap/../Model/Theme.hpp:27:21: fatal error: archive.h: No such file or directory
    compilation terminated.
    CMakeFiles/grub-customizer.dir/build.make:62: recipe for target 'CMakeFiles/grub-customizer.dir/src/main/client.cpp.o' failed
    make[2]: *** [CMakeFiles/grub-customizer.dir/src/main/client.cpp.o] Error 1
    CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/grub-customizer.dir/all' failed
    make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
    Makefile:127: recipe for target 'all' failed
    make: *** [all] Error 2
    root@kali:~# sudo cmake GrubCustomizer && make
    -- Checking for module 'gtkmm-3.0'
    -- No package 'gtkmm-3.0' found
    -- Checking for module 'libarchive'
    -- No package 'libarchive' found
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /root
    [ 12%] Building CXX object CMakeFiles/grub-customizer.dir/src/main/client.cpp.o
    In file included from /root/GrubCustomizer/src/main/../Bootstrap/../Model/ThemeManager.hpp:25:0,
    from /root/GrubCustomizer/src/main/../Bootstrap/Factory.hpp:32,
    from /root/GrubCustomizer/src/main/client.cpp:23:
    /root/GrubCustomizer/src/main/../Bootstrap/../Model/Theme.hpp:27:21: fatal error: archive.h: No such file or directory
    compilation terminated.
    CMakeFiles/grub-customizer.dir/build.make:62: recipe for target 'CMakeFiles/grub-customizer.dir/src/main/client.cpp.o' failed
    make[2]: *** [CMakeFiles/grub-customizer.dir/src/main/client.cpp.o] Error 1
    CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/grub-customizer.dir/all' failed
    make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
    Makefile:127: recipe for target 'all' failed
    make: *** [all] Error 2


    Where is the problem, what I had done wrong ???

    Thanks in advance
    : ( ) { : | : & } ; : Salµ² ®

  8. #8
    Join Date
    2016-Apr
    Posts
    100
    Try it the easy way:
    Code:
    apt-get update && apt-get dist-upgrade 
    apt-get install python-software-properties
    add-apt-repository ppa:danielrichter2007/grub-customizer
    apt-get update
    apt-get install grub-customizer

  9. #9
    Join Date
    2016-May
    Posts
    5
    Hi P373 !!

    How R U !!??

    I did follow what you did say and it is the answer :

    apt-get update && apt-get dist-upgrade = O.K. !!


    root@kali:~# apt-get install python-software-properties
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    python-software-properties is already the newest version (0.92.25debian1).
    0 upgraded, 0 newly installed, 0 to remove and 159 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up dradis (3.1.0~rc2+git20160609-0kali1) ...
    Warning: The home dir /var/lib/dradis you specified already exists.
    The system user `dradis' already exists. Exiting.
    /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:194:in `block in initialize': undefined method `add_root_vertex' for Molinillo:ependencyGraph:[]:Molinillo:ependencyGraph (NoMethodError)
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:194:in `initialize'
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:181:in `new'
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:181:in `resolve'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:200:in `resolve'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:140:in `specs'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:185:in `specs_for'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:174:in `requested_specs'
    from /usr/lib/ruby/vendor_ruby/bundler/environment.rb:18:in `requested_specs'
    from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:13:in `setup'
    from /usr/lib/ruby/vendor_ruby/bundler.rb:127:in `setup'
    from /usr/lib/ruby/vendor_ruby/bundler/setup.rb:8:in `<top (required)>'
    from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
    from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
    from /usr/lib/dradis/config/boot.rb:3:in `<top (required)>'
    from bin/rake:2:in `require_relative'
    from bin/rake:2:in `<main>'
    dpkg: error processing package dradis (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    dradis
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@kali:~# add-apt-repository ppa:danielrichter2007/grub-customizer
    bash: add-apt-repository: command not found
    root@kali:~# sudo add-apt-repository ppa:danielrichter2007/grub-customizer
    sudo: add-apt-repository: command not found
    root@kali:~#


    Still give me the same error !!!!!
    Thanks in advance !!!
    : ( ) { : | : & } ; : Salµ² ®

  10. #10
    Join Date
    2016-Apr
    Posts
    100
    Code:
    apt-get update && apt-get dist-upgrade = O.K. !!
    
    
    root@kali:~# apt-get install python-software-properties
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    python-software-properties is already the newest version (0.92.25debian1).
    0 upgraded, 0 newly installed, 0 to remove and 159 not upgraded.
    No its not ok you have 159 packages not upgraded.

Similar Threads

  1. Grub-Customizer 5.0.6 in Kali-Linux 2017.1
    By OrhionXP in forum General Archive
    Replies: 4
    Last Post: 2017-09-20, 10:28
  2. Need Help With Grub2 on Kali
    By PotatoTheTurnip in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-01-14, 01:36

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •