Results 1 to 3 of 3

Thread: Does anyone have problems with Terminal on Nethunter 2022.1?

  1. #1
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    104

    Does anyone have problems with Terminal on Nethunter 2022.1?

    Hi, I have Kali Nethunter on Nexus 6P. LineageOS 17.1. Unofficial. I just reinstalled LineageOS. Wiped System, Data, Cache and Dalvik. Everything works. Then I installed Nethunter. 2022.1. Magisk Root. Updated. I used to have Nethunter 2021.2. Worked fine. Terminal was good. I had problems with 2021.4. Terminal was weird. Bash. So, I updated to Nethunter 2022.1. Downloaded from Kali.org. Wiped LineageOS 17.1. After installing Nethunter, I booted into Lineage. Flashed Nethunter in TWRP. I granted Permissions etc... When I open the Terminal, it shows the Word "kali#". No "root@kali". It shows an error:

    "zsh: failed to load module 'zsh/zle': /usr/lib/aarch64-linux-gnu/zsh/5.8/zsh/zle.so: cannot open shared object file: Operation not permitted."

    Then I tried apt-get update. It says:

    "sudo: apt-get: command not found
    zsh: operation not permitted: /var/mail/root."

    And "cd" doesn't work.

    "cd: operation not permitted: /opt
    zsh: operation not permitted: /var/mail/root."

    Does anyone else have this problem? Is it 2022.1? Bash? How do I get the normal Terminal? "root@kali"? Please reply. Thanks

  2. #2
    Join Date
    2022-Apr
    Posts
    2
    Unfortunately, I also encountered this problem.


    But I tried to install busybox from Google play to help install these commands.

    At least I can run these basic commands on the command line.

    I hope it can help you, my friend.

  3. #3
    Join Date
    2014-Dec
    Location
    Indianapolis, Indiana
    Posts
    104
    Hi, I'm back. I reinstalled LineageOS 17.1. Wiped. Formatted. And installed Kali Nethunter 2022.2. Nexus 6P. Same error. "zsh..." I searched online. Found a Thread. They fixed it by flashing TWRP. FBE-10-TWRP. I'm currently using FBE-10-4core. I need it to boot. No Boot-Loop. I might try flashing FBE-10-TWRP. I'm worried it will break the install. Back to Boot Loop.

    I will try Busybox. I don't have Gapps. I've had it before. I will report back. Any ideas? Thanks

    Edit: Older builds worked. 2021.1. The problem started with nethunter 2021. At the end of 2021. I can try the older Build. I would like the Newest.

Similar Threads

  1. problems with terminal
    By shiro335 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2021-10-26, 01:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •