(Kali 1:1.27.2-2kali1)
I installed Kali Linux light 32bit onto my laptop HDD which already contains windows 7 x86 using a usb stick made bootable with Rufus. I rushed through the process and clicked on "use all partitions(for new users)" and then it seemed like the installation was done. But when it automatically rebooted the system grub was gone and the s/m went into grub rescue..I tried "ls,set prefix,set boot" with the partitions listed,none of them got me into "insmod normal"..so I decided to reinstall everything..but this time I saw that the internal disk was on /device/sdb and not sda..so I chose sdb1..then installed by skipping network configuration and completing installation..now when it restarts the grub appears to be made only of Kali as follows..
Advanced Kali(gnu/debian)(recovery)
Kali(gnu/debian) --rolling on /dev/sdb5
Advanced(gnu/debian) --rolling on /Dev/sd5 (recovery)
And the windows 7 is nowhere to be found.
The third and fourth one won't work..don't have any clue why..
On clicking the first and second one (at different times) I ended up with the same error "bunch of acpi error.. lookup failure and ALERT! /Dev/sdb1 does not exist"
Then it drops to a shell and shows (initramfs) in busybox v1.27.2.. then I used the usb stick to enter into Kali live only to see my partitions were nowhere to be seen instead only the root partition is present..when i click on the partitions saying Kali live it says "/Dev/sda not mounted etcc"..I don't really know what to do at this point..kindly help me..