I just installed kali v2020.1b on a vm in virtualbox.
The installation phase kept giving me errors, I tried basically for 3 days to install the system but kept failing at "Select and Install Software". I searched a bit and found that probably the packages in the image were buggy, so I went for the net-install version


and finally the installation completed.
So after rebooting no GUI is showing up, even if I choose the xfce4 during the installation (the Kali's default one). I try launching the GUI with startx but the command is not found.
So after that I tried to install Gnome with

sudo apt-get install gdm3

but kept getting hash sum mismatches and apt kept failing getting the packages.
So I tried first to update apt via apt-get upgrade but even here the packages are failing to download, giving a hash mismatch error.
I tried cleaning the cache with

apt-get clean
rm -rf /var&lib/apt/lists/*

but nothing the files can't download. Now I can't even launch the gnome installation as the command gives me unable to locate package gdm3.

Does someone have any ideas? Are the packages corrupted in this new version? I think that the constant failures during the installation and this ash mismatches are correlated but I don't know what to do as I'm pretty a noob in linux. Am I doing something wrong?