i found this question on the archive forums but with no solution.

when i run
ssh username@host
nothing happen until disconnected after some time because i didn't provide password..!, i mean no output or prompt for password, absolutely nothing, same thing using root (sudo su).
i just keep looking at the cursor blinking, that's all.
i installed "putty" on kali and it works but i don't like the putty console, no copy or past and not practical at all.
i installed "plink" and it worked perfectly but why my ssh is not working [not showing any output]?

my kali version:
5.10.0-kali9-amd64 #1 SMP Debian 5.10.46-4kali1 (2021-08-09) x86_64 GNU/Linux
running from VMware on Windows 10.
what i tried so far: [but no success!]

  1. checking ssh service if running, and guess what " it is running"
  2. changing terminal to xterm, executing ssh from bash, always nothing happen, so it is not terminal issue.
  3. restart ssh service.
  4. reinstall ssh
  5. delete all folders related to ssh
  6. update and upgrade kali for latest version
  7. searched everywhere nothing seems helping to me
  8. installed "strace" and traced the ssh command and this is the output: