Results 1 to 5 of 5

Thread: ARM build scripts?

  1. #1
    Join Date
    2022-Jul
    Location
    New York
    Posts
    3

    ARM build scripts?

    Hello,

    I've tried to build images for Raspberry Pi (32 and 64 bit) and Beaglebone Black (same) and every time I end up with errors like this:

    Code:
    /tmp/cchjW2EZ.s:74: Error: selected processor does not support `dmb ish' in ARM mode
    The unsupported instructions vary, but the error message is the same.

    I cloned the ARM build scripts from the kali-arm repo at Gitlab according to the docs. I've tried to build these on Kali VMs under VirtualBox and also on native installs on a Raspberry Pi 4. Both hosts yield the same errors.

    Am I missing something? Is there a different package I need to install, or a configuration I need to change on an existing one?
    "If it ain't broke, I'll fix it!"


  2. #2
    Join Date
    2021-May
    Location
    UK
    Posts
    420

  3. #3
    Join Date
    2022-Jul
    Location
    New York
    Posts
    3
    Quote Originally Posted by Fred Sheehan View Post
    I did search for some help, and I saw that post. I realize I need the compiler to build for the neon FPU but that article doesn't say anything about how to get the Kali build script to do it.
    "If it ain't broke, I'll fix it!"


  4. #4
    Join Date
    2014-Feb
    Posts
    309
    How are you running the scripts? That seems like it's trying to use an arm64 (64-bit) compiler to build armhf (32-bit) which isn't going to work. The BBB script likely needs some work and is considered "community supported" but the Raspberry Pi scripts are all maintained, and they get built every day, as well as once a week.

  5. #5
    Join Date
    2022-Jul
    Location
    New York
    Posts
    3
    Quote Originally Posted by steev View Post
    How are you running the scripts? That seems like it's trying to use an arm64 (64-bit) compiler to build armhf (32-bit) which isn't going to work. The BBB script likely needs some work and is considered "community supported" but the Raspberry Pi scripts are all maintained, and they get built every day, as well as once a week.
    I got the same errors when I tried to use the Raspberry Pi script to build an image for a Pi 2, so whatever is causing it does seem to be common to the ARM tools. I ran both scripts on a Kali VM with the --arch armhf option.

    I found a commit message for one of the scripts somewhere (which I can't find again, unfortunately) that said the later version of the ARM compiler (I think it was version 11 at the time) had changed how it recognized the FPU selection. (Or maybe the default selection?) I installed version 10 of the tools and made them the default on my VM and was able to build images for both the Pi 2 and (as of yesterday) the Beaglebone Black as well. So my question has been resolved.

    Thanks!
    "If it ain't broke, I'll fix it!"


Similar Threads

  1. Replies: 0
    Last Post: 2021-04-30, 09:27
  2. Source build way smaller than pre-build?
    By xNotta in forum Building NetHunter
    Replies: 1
    Last Post: 2016-12-20, 02:28
  3. Tuning arm-build-scripts
    By db5fx in forum ARM Archive
    Replies: 0
    Last Post: 2016-01-12, 09:03
  4. Kali Arm Build Scripts
    By Wazabee in forum Building Archive
    Replies: 1
    Last Post: 2015-02-08, 20:36

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •